PTV Visum Tips & Tricks

 How can PTV Visum integrate isolated stops into the network?

Aggregation of isolated nodes
This screenshot shows the results of the aggregated nodes, which have been isolated before.

How can PTV Visum integrate isolated stops into the network?

 

You have a private transport (PrT) network, including stops from public transport (PuT), but these stops are isolated (means that they are not on links or nodes). How can automatically assign the stops on links?

One approach is to use the “Aggregation of isolated nodes” (choose nodes, then right mouse click). There you can choose, whether the stops (nodes) shall split the link or shall be placed on the link.

Depending on your task you might also want to look at the new PTV Visum 14 feature “PuT supply from PTV Visum” which allows you to bring the whole PuT supply (stops, lines, etc.) from one network into another network. You will find this function under “File > Import > PuT supply from PTV Visum”. Watch here a video from our colleague Manuel Galster about this feature.

 Catchment areas, accessibility of places in the network

Fixed radius of 500m
PrT 5 min steps of tCur in smooth colour transition.
Number of inhabitants reached in a radius of 500m around stop areas
4 POIs for PrT tCur of 5min, 10min, 15min, 20min intersected with zone inhabitants

Catchment areas, accessibility of places in the network

Accessibility is an important factor in traffic planning. PTV Visum can graphically represent how accessible places in the network are, how large the catchment area for stops and lines is, for example, and what proportion of the inhabitants are connected to the traffic network, and how well.

In the following, we will present five display options for accessibility:

  1. Stop catchment areas
    Using stop catchment areas, you can illustrate the PuT access quality in the network.
    The layer 'Stop catchment areas' can be selected in the graphic parameters. Here, either a fixed radius or a selected attribute for the radius around the stop area can be indicated.
    (See figure 1)

  2. Isochrones
    Based on one or several selected network objects, isochrones visualize the accessibility of all other network objects. Accessibility can be classified in intervals that are displayed in the network editor with different colours. Here is a PrT example, which displays the time in the loaded network with a smooth colour transition based on a node. (See Figure 2)

  3. "Intersection" GIS functionality
    In Visum, you can intersect any network objects of the type point, line, or polygon that overlap spatially.
    For example, if the number of inhabitants in zones is intersected with stop points with a circular area (buffer with radius), the proportion of inhabitants who have a specific distance to stop points is shown.  (See Figure 3)

  4. Isochrones and intersections
    Isochrones are only displayed graphically and no network elements.
    The add-in "2D-Isochrone -> POI" can be used to change isochrones into network elements to enable their intersection as area objects with other network objects.
    (See Figure 4)

  5. Intersection of lines
    Line routes can be intersected with attributes of zone areas by setting a buffer size around the line route, but this cannot be visualized
    Such line buffers can also be created as POI areas with the Visum add-in "Buffers around PuT lines" and in this way be graphically displayed and intersected.

 Renumbering network objects

Screenshot 1
Screenshot 2
Screenshot 3

Renumbering network objects

Is it possible to re-name links, nodes or zones, to release partly occupied numbering ranges? Yes, a new feature in Visum 14 offers for many network object classes the function "Renumbering":

  • Nodes
  • Links
  • Zones
  • Main nodes
  • Main zones
  • Territories
  • POIs
  • Screenlines
  • Count locations
  • Detectors
  • Stop points
  • Stop areas
  • Stops
  • Lines (Vehicle journeys/Coupling sections)

    -> (Right click to open the context menu) -> Renumbering (Screenshots 1-2)

    Without this feature a model might run out of available IDs. The suggested value for the ID-offset when reading additively or when using model transfer files is always the highest existing ID+1. Thereby in many cases (particularly by using external identifiers for IDs), long IDs could develop which may cause overflows.

    With Visum 14, reading a network additively offers a new conflict avoidance option, to renumber the IDs for multiple network object classes (Screenshot 3). The “offset” holds the count for the existing network objects, which are renumbered from 1, and this counting is continued for the new added objects.

    A workaround for Visum 13 and older uses a script solution, which is available in our FAQs.
    For anyone who still wants to perform any renumbering per COM: Visum 14 offers for many more network object classes as listed above the COM method “Renumber”.

     Data export to MS Excel: storing correct numerical values

    Data export to MS Excel: storing correct numerical values

    When exporting or copying to Excel (by file or clipboard, of lists or matrices) number formats or number values are sometimes changed. Why?

    This might be related to the setting for the decimal symbol as point or comma, which needs to be equal for both Visum and Excel:

    • Excel can use the corresponding Windows setting: Control panel -> Regional and Language -> Format -> Additional settings/Customize -> "Decimal symbol" and "Digit grouping symbol".

    • Excel 2010 can override this option: Excel Options -> Advanced -> Use system separators -> "Decimal separator" and "Thousands separator".

    In Visum this is a program setting:

    • Visum10/11/12: Extras -> Options -> Formats -> Decimal separator.

    • Visum13/14: Edit -> User Preferences -> Formats -> Decimal separator.

     Displaying flow bundles as link flow shares

    Figure 1
    Figure 2
    Figure 3
    Figure 4

    Displaying flow bundles as link flow shares

     How can I display a flow bundle as a percentage of link flows?

    1. Use a user defined attribute of type "Formula", calculated as:
      VolFlowBundle(PrT) / VolVehPrT(AP).  (Figure 1)

    2. The respective link bar is set to be displayed with the format "Percent": Edit graphic parameters -> Links -> Bars -> Display -> Edit bar ... -> Label -> Format = Percent (Figure 2)

    3. To respect proportionality, display the flow bundle as bar (but without label: "Show Value/Unit/Title" off), and the user defined attribute only as label (without bar: ScaleMaxWidth = 0). (Figure 3)

    The result is displayed in Figure 4.

     Creating a correctly scaled network from the scratch

    Creating a correctly scaled network from the scratch

    Often seen: A small network, created to test some functionality, to make a quick estimation or to contribute to a larger network. How to set it up smart and effectively?

    This article describes a way to create a stable fundament for any network, fast and suitable for every place in the world.

    Read more...

     Colorize zones individually

    fig. 1
    fig. 2
    fig. 3
    fig. 4

    Colorize zones individually

    A classic GIS application: How to colorize a map to ensure that neighbouring countries never share the same colour?

    Transferred onto PTV Visum: How to colorize zones individually?
    (see fig. 1)

    To create such a map with PTV Visum, proceed this way:

    • In the dialog "Edit graphic parameters" use the "Classified drawing mode". You might use the zone number, but better take a recurrent numbered attribute, like AddVal1 or a user defined attribute. Its values can be set using a COM script, for which some small examples can be found here. These illustrate how simple PTV Visum can be automated. Moreover, these VBA examples use, instead of CreateObject, PTV Visum as a referenced library, offering drop down menus with an overview over all available properties and methods while writing the code.
    • In the same dialog, you can define the classes and their colours manually. (see fig. 2)

    Alternatively use the dialog "Edit classification: Change colours" and choose in the colour scale's dropdown menu the entry "Create qualitative scale for current number of classes". (see fig. 3)

    The result is not perfect, but in case of neighbouring zones sharing the same colour, you only need to change the used attribute's value.
    (see fig. 4)

     Setting up a calendar day or time interval filter in the Timetable editor

    Fig. 1
    Fig. 2
    Fig. 3

    Setting up a calendar day or time interval filter in the Timetable editor

    How to set up a filter for a calendar day or time interval in the Timetable editor?

    For this purpose, the line filter is very suitable:

    • In the “Vehicle journey“ tab, a time interval over a couple of hours can be defined for departures between i.e. 2 PM and 4 PM (see fig. 1)
    • The Timetable editor can take this filter into account
      (see fig. 2): Click the highlighted button.
    • In the “Vehicle journey section” tab, the filter can be set
      (additionally, if applicable) to a certain valid day (see fig. 3)

     Editing the polygon of area objects

    Editing the polygon of area objects

    PTV Visum uses area objects for zones, territories, POIs, main nodes, main zones and toll systems, and offers a comfortable editor for their closed polygons. Are you sure to know all really helpful features available?

     Memory RAM insufficient. What can you do?

    Memory RAM insufficient. What can you do?

    In principle every new release is more demanding regarding memory. The aim is to get faster and getting faster more often is accompanied by an increase in memory consumption. When using multi core processors, data also has to be stored multiple times, for example. So what can you do to save memory or have more available memory?

    1) Use PTV Visum-64-Bit

    2) Application of the 3-GB-option of Windows XP

     

    The 3-GB-option of Windows XP is also possible for other operating systems. Operating systems can be configured to allocate more memory to applications.

    3) Using the matrices cache of PTV Visum

    In order to use the matrices cache of VISUM in the menu "Extras->Options->Files&protocols->Matrices" you activate the function “Activate swap file“. The “Maximum size of matrix data stored in RAM” should be as small as possible.

    4) Load matrix data if required

    If you are working with many matrices but they are not needed immediately and at the same time, via the menu File->File properties “Lagged matrix data loading on demand” you can save memory. This setting is saved in the version file and will be executed when reading it the next time.

    5) Execute with one CPU core

    Several procedures require less memory if executed only with one CPU core (set under "Extras->Options->Environment").

     Bar labels

    Bar labels

    • Links have the attributes “Show bar text“ and “Bar text relative position”. These attributes may be changed for single links with "Show/Hide labels" (F4) and "Shift label" (F6). (Figure "Linkbar text")

    • Attribute “Show bar text” has a value of Yes/No respectively 1/0. If i it is set to “No”, no bar text will be displayed. IF set to “Yes”, the text will be shown if there is enough space.

    • “Bar text relative position” has the value 0.5 as a default, which means link bar will be labeled in the middle. BTW a link with shifted bar text will always show the text even if there is not enough space. You can therefore use it to force labeling.

    • Like other attributes they can be listed, filtered or set via Multi-edit. For Multi-edit also via “Special functions/Labels”. (Figure "Linkbartext_Multi-edit")

    • If links are digitalized (have graphical intermediate points) or there are many short links, labeling easy is left our because it no longer fits.

      • A bar text doesn’t fit if its length is bigger than the distance between From Node and To Node.

      • If there are many short links with two arm nodes, it’s possible to change these nodes to graphical points of links with Nodes->Multi-delete and “Connect links”.

      • In the graphic parameters under Bars->Text format “along the longest section” is set as default. If “in the middle” is chosen instead, more shaped links will show the bar label.

    Linkbartext
    Linkbartext_Multi-edit
    "In the middle"
    "Longest segment"

     How to add a correctly georeferenced GoogleMaps aerial image

    How to add a correctly georeferenced GoogleMaps aerial image

     How to choose an appropriate coordinate system

    How to choose an appropriate coordinate system

     Digitizing areas using catch points and zoom function

    Digitizing areas using catch points and zoom function

    The Digitize mode ( e.g. of zone borders) does not allow you to zoom across the toolbar or move display details. The relevant function is greyed out (Image 1). From PTV Visum 11.5, however, you will be able to catch the points of common areas.

    If too many points are too close to each other, you'd normally first have to switch to the Zoom mode again (Image 2). But now you can also zoom using the mouse wheel. If you want the mouse pointer to be in the focus while zooming, keep the CTRL key held down while turning the mouse wheel. You can also use the Page up and Page down keys for zooming. Use the arrow keys if you want to move the network.

     

    Image 1
    Image 2

     Multi-editing attributes

    Image 1
    Image 2
    Image 3

    Multi-editing attributes

    There are at least 3 ways to change all or all active attributes.

    1.   To multi-edit network objects directly, from the shortcut menu, choose "Multi-edit".
      (Image 1).
    2. If you want to use a procedure, choose the "Edit attribute" function. Since procedures are saved as procedure parameters and these are saved with the version data, you can reuse them without having to enter them again. (Image 2).
    3.  Add-in (under Scripts/VisumAddIn)
      The "Multi-edit attributes" add-in provides the widest range of functionality. Besides offering predefined functions, it allows you to use your own, complex functions. By including your own functions in a procedure, you also save them. (Image 3).

     Keep an eye on 64-bit compatibility in Python-scripts

    Keep an eye on 64-bit compatibility in Python-scripts

    Every now and then we receive inquiries from users who find that the Python scripts they used successfully under PTV Visum 32-bit no longer work under PTV Visum 64-bit. In our experience the reason is in most cases that the script uses a Python library which is not yet available in a 64-bit version. Two typical cases are GDAL (for GIS functions) and tkinter (for graphical user interfaces). In the case of gdal we hope that the ongoing effort in the open source community will soon produce a stable 64-bit version, which we will then make available for PTV Visum. In the case of tkinter we urgently recommend that you implement the graphical user interface in wxPython instead. There is no indication that a 64-bit port of tkinter is forthcoming, and wxPython GUIs conform more closely to the Windows look and feel. All of the add-ins that come with PTV Visum now use wxPython. If you still observe error messages pointing to tkinter, it is an indication that your installation is not up to date and applying the latest service pack should fix the problem.

     Mouse navigation within the network

    Mouse navigation within the network

    The middle mouse button or mouse wheel allow you to temporarily switch to "manual" mode.

     Column diagram

    Column diagram

    Figure 1

    There are now some useful features available for displaying data in a column diagram:

    • Negative values are shown as downward columns
    • You can set the number of decimal places for labeling
    • You can specify a minimum value: "No column for values <= x"

     Comparative operators in filter conditions

    Comparative operators in filter conditions

    Figure 1

    Within a filter condition you can now also use brackets and comparative operators, e.g. Attr1 < Attr2

     OD pair filter

    Figure 1

    OD pair filter

    The OD pair filter is fundamentally different from the network object filter, since it filters origin-destination pairs between zones and cannot be used to set network objects active or passive. In the graphic display and in lists, the OD pair filter has an effect on all volume skims.

    • Flow bundles and turn volumes
    • Volumes of links, connectors, turns and PuT lines
    • Boarding, alighting, and transfer passengers at stops

    You now have the option to switch off the recalculation of network volumes (see figure 1).
    You can e.g. use the filter (without the recalculation function) for the following:

    • Shortening of OD pairs list
    • Filtering paths of a path set
    • Procedures with filtered OD pairs:
      *PuT assignment
      *Combining matrices and attribute vectors
      *Trip distribution
      *Assigning a matrix to paths
    • Saving matrices as partial matrix in O format

     Adopting graphic parameters for link bars

    Adopting graphic parameters for link bars

    Link volumes can be graphically displayed as link bars. You can now adopt user-defined settings made for one bar for other bars, so that you need not specify the same settings again (fig. 1):

    • Click the [+] button to copy the current settings of a bar and adopt them for other bars

    Figure 1

     Difference network/ Version comparison function

    Figure 1

    Difference network/ Version comparison function

    The "Difference network" allows you to compare two networks and show the differences between them.

    • From PTV Visum 11.5, this procedure is simplified with the introduction of the "Version comparison" function (fig. 1).
    • Using the "Version comparison" function, you can edit the network and perform procedures (not so in the Difference network mode).

     Filter in lists and timetable editor

    Figure 1

    Filter in lists and timetable editor

    You can now set filter conditions in the Timetable editor with the click of a mouse button, e.g. when the Quick view and Overview window are hidden:

    • Right-click to go to the Filter dialog (fig. 1)

     User-defined attributes

    Figure 1

    User-defined attributes

    • You can now create user-defined attributes even easier and quicker, namely via the shortcut menu (fig. 1)
    • For attribute selection, the user-defined attributes are highlighted with a dark red circle.

     Additive reading of network files

    Additive reading of network files

    If you want to add further network data to an existing network in PTV Visum, without losing the existing data, these can be read in additionally with the following steps:

    1. The network data which you want to add, has to be in ASCII format "Networks" *.NET (therefore no version file)
    2. MENU: File -> Open -> File type select "Networks" -> ok
    3. Select the corresponding file to be read additionally
    4. Activate the button "Reading network files additionally"
    5. If the button "First off, determine tables in file" is active, the network file is first read, so that it can be displayed for the user, which table is contained in the network file.
    6. Tables can now be selected for adding.
    7. If a network element already exists which should be added (e.g. Node 100 already exists), different options can be selected for conflict handling:

      • The new information is ignored
      • The network element attributes are overwritten
      • The network element object is overwritten. This means, that the network element is first assigned with standard attributes and the new attributes are then read.
      • If the network element already exists in the existing network, additional reading can be canceled.

    8. Furthermore, conflict avoidance can be activated in the same window "Read network data additionally". This would mean, that a new element always has to be created, which then however receives a different relation (for example Node 100 is added with a predefined offset, in order not to occur twice).

     Import GPS Points

    Image 1
    Image 2
    Image 3
    Image 4

    Import GPS Points

    Customers often ask us how GPS points in WGS84 can be imported in VISUM. The simplest way is, by saving a small network file and supplementing the point data by the column format NO;X-Coordinate;Y-Coordinate.

    This is how it works:

    1. Start PTV Visum.
    2. Set the desired coordinate system: Network -> Network parameter -> Coordinate system -> Radio button "from file" -> Button "..." -> Dialogue projections -> Geographic Coordinate Systems -> World -> GCS_WGS_1984 / WGS 1984.prj -> Ok -> Ok.

     

    (If the coordinate system is double-clicked, the projection dialogue is closed automatically.)

    1. Insert a node.
    2. Save as a network file (File -> Save as -> File type selection -> Networks)
    3. In the dialogue "Save network" activate the button "All tables OFF" and only activate the object types network parameters and nodes.
    4. Under "Node" make all fields visible and deactivate all fields except NO, XCOORD and YCOORD. (image 1)

     

    (Admittedly this is laborious. Did you know that in the dialogue, you can navigate using the arrow keys and activate or deactivate entries using the space bar?

    Of course you can also save a layout and keep it for later.

    Tip: Did you know, that a network file is also written, where only the buttons of the table are included? These can also be changed very easily with a text editor.

    Exit the dialogue with OK.

    1. The file created can be opened with a text editor. The only row under the header "$Node…" codes according to the column format

    NO;X-Coordinate;Y-Coordinate
    and can be replaced by other rows with the same format. (image 2)

    Attention: The number groups of this node should not overlap with the number groups of the nodes in the version file, to which these nodes are written.

    In principle POI objects can be used instead of nodes, but in this case a POI category has to be created first. In the dialogue "Save network" activate the object type POIOFCAT_1 and the column format looks slightly different.

    The contents of this network file can now be added to a version file:

    1. Open the PTV Visum version file.
    2. First set your coordinate system of your network file to WGS84 (see Point 2).
    3. Then read the network file: File -> Open -> File type selection -> Networks -> Specify file name and location -> Read dialogue network -> Read network file additive -> Additionally read dialogue network data -> OK.
    4. Finally set the coordinate system back to the original system. (image 3)

    Tip: The now read nodes can be displayed via the graphics parameter and filter their properties as isolated nodes. To do so, create a filter with the attribute NumLinks and the value range up to 0.   (image 4)


     Google Maps Add-In

    Google Maps Add-In

    This add-in allows you to visually inspect the surroundings of a network node or main node in Google Maps. This can be a handy shortcut, if you wish to check the correctness of the junction model.

    Method

    The add-in calls up a satellite map of the surroundings of the node or main node in Google Maps and displays the result in your Web browser.

    In order to convert the position of the node to latitude / longitude, Visum needs to know the projection used for the coordinates in your model. Be sure to set the projection under Network – Parameters before using the add-in. In some cases the third-party library used for the reprojection fails to convert from the Visum projection to lat/long. In those cases you can try switching manually (in Network – Parameters) to WGS_1984. Don’t forget to switch back when you are done, if you plan to save your changes.

    The add-in assumes that you have a Web browser installed on your computer and it is set up as the default program for files with extension “.htm”. You also need a connection to the Internet while using the add-in.

     

    Parameters

    Start by marking a single node or main node in the network editor.

    Zoom level: A number describing how far Google maps should zoom in to the coordinates of the node. A level of 19 usually results in a view that is detailed enough to see lane markings etc. if present. Use a lower number if Google complains that it does not have maps down to this resolution, or if the coordinate match is less than perfect.

    Click Display to show the map for the currently marked node or main node. The window will remain open, so you can mark and display further nodes. Click Close when done.

     Speed up version file loading by using the matrix swap file

    Image 1
    Image 2

    Speed up version file loading by using the matrix swap file

    Since PTV Visum 11.02-02 on loading a version file, PTV Visum can optionally load any contained matrices on demand, i.e. leave their data in the version file until they are actually accessed.

    This will speed up version file loading, especially if you do not need the matrices for what you are about to do with the model, for example only view volumes in the network.

    Using this option, the time PTV Visum needs to read additional matrix data, does not effect the performance.

    In order to benefit from deferred loading you need to activate this behaviour per version file:

    1. Start v and make sure the matrix swap file is activated: Options => Files & Protocols => Matrices => Activate “Enable matrix swap file” (image 1). (Tip: 512Mb is the default value for the maximum size of matrix date stored in RAM, but you can choose a very small value too.)
    2. Load the version file.
    3. File => File properties => Activate “Lagged matrix data loading on demand” (image 2).
    4. Save the version file. This might in some cases take a little bit longer.

    The effect with version files holding numerous, large matrices might reduce the loading time up to 90%.

     "Check network" feature in PTV Visum

    This is the "Check network" dialog
    With “run tests” the network check is performed. After this, a symbol is displayed next to each topic that shows the status of the check
    If it is not marked with "OK", but with an exclamation mark, then errors were found. After clicking a “!”-button, a dialog like this opens, enabling a quick investigation (“Set to the active state”) and even to fix the problem immediately (“Delete”)
    If you leave the "Check network" dialog, you are asked wether you want to view the error log

    "Check network" feature in PTV Visum

    Easily forgotten and overlooked, but extremely powerful and helpful the "Check network" feature (Calculate menu) in Visum.

     

    You can use it to check for mistakes or weak spots in the network. The results of the check are written to a file that you can view directly in PTV Visum. It is convenient that after the check you can fix the problem immediately or quickly check "suspicious" network elements by setting them active. All other network elements become passive, thus enabling you to highlight these network elements graphically or list these seperately.